[ewg] [PATCHv8 08/11] mlx4: Allow interfaces to correspond to each other

Roland Dreier rdreier at cisco.com
Wed May 12 13:30:22 PDT 2010


 > +void *mlx4_get_prot_dev(struct mlx4_dev *dev, enum mlx4_prot proto, int port)
 > +{
 > +	return mlx4_find_get_prot_dev(dev, proto, port);
 > +}
 > +EXPORT_SYMBOL(mlx4_get_prot_dev);

Not sure I understand why you have a wrapper to call another function
with exactly the same parameters?  Can't we get rid of this and just
rename mlx4_find_get_prot_dev() to mlx4_get_prot_dev()?
-- 
Roland Dreier <rolandd at cisco.com> || For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/index.html



More information about the ewg mailing list