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1 Introduction 
EEPROM Command Center (ECC) is a client software application which allows the user to: 

 Monitor the state of QSFP EEPROM 

 Write to writable fields of the QSFP Memory Map 

 Save statistics and parsed memory map fields to file 

 

The monitoring capabilities of ECC are useful for detecting changes to the Memory Map of a 

QSFP Device Under Test (DUT) while performing external testing (such as InfiniBand ATD 

testing) while the write capabilities allow configuring the QSFP device via its memory map. 

 

EEPROM Command Center utilizes Total Phase, Inc. Aardvark I
2
C/SPI Host Adapters in order 

to interface with an I
2
C Module Control Board (MCB) in order to read/write with a QSFP 

device. 

 

This software comes bundled with the necessary library files to interface with the Aardvark API 

in agreement with Total Phase, Inc. (see accompanying license documentation), however, Total 

Phase, Inc. is in no way affiliated with Software Forge, Inc. or EEPROM Command Center. 

 

2 System Requirements 

Operating Systems 
 Windows Vista or higher 

 Linux 

Architecture 32 bit or 64 bit 

CPU 2+ Core @ 1.8 GHz or higher 

Memory 4 GB or more 

Additional Hardware 
 (2) Aardvark Host Adapters 

 (2) QSFP I
2
C Module Control Boards 

Additional Software 
 Aardvark driver (see section Aardvark Driver for 

additional information) 

 

  

http://www.totalphase.com/products/aardvark-i2cspi/
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3 Installation 

3.1 Windows 

Obtain the correct installer file for your CPU architecture (32-bit or 64-bit) and run the installer 

on the machine where ECC should be installed as administrator.  Follow the on-screen 

instructions to complete the installation procedure. 

 

3.2 Linux 

Linux installers are available for Debian-based and RPM-based distributions.  Obtain the correct 

installer file for your distribution and CPU architecture (32-bit or 64-bit) and run the installer on 

the machine where ECC should be installed as root.  For GUI-based installers, follow the on-

screen instructions to complete the installation procedure. 

 

3.3 Aardvark Driver 

ECC is bundled with the necessary Aardvark library files but additional setup is necessary for 

enabling driver support for the Aardvark Host Adapters. 

 

3.3.1 Windows 

Total Phase has a custom USB driver for Windows which can be downloaded from their website.  

See the Aardvark User Manual for additional driver installation instructions. 

 

3.3.2 Linux 

The Aardvarks run on a modified version of the libusb open source library.  A one-time 

configuration is needed in order for the driver to function correctly for the Aardvark devices.  

The necessary configuration files can be downloaded from the Total Phase website.  Then, 

perform the following steps: 

 

1. Move the 99-totalphase.rules configuration file to /etc/udev/rules.d. 

2. Run command chmod 644 /etc/udev/rules.d/99-totalphase.rules. 

3. Unplug and replug any Aardvark adapters which were connected to the host machine. 

 

For more information about the Aardvark drivers and their setup, see the Aardvark User Manual. 

 

4 Hardware Configuration 
The host machine running the EEPROM Command Center software must be connected to two 

Aardvark Host Adapters via USB connection in order to be able to interface with both ends of a 

QSFP cable.  Each Aardvark must then be connected to an individual I
2
C MCB via the Aardvark 

pinout connectors.  Only the Ground (GND), Serial Clock Line (SCL), and Serial Data Line 

(SDA) connectors need to be connected to the MCB in order to enable I
2
C communications.  See 

the Aardvark User Manual for more information about the Aardvark Host Adapters.  Each end of 

the QSFP cable is then connected to an MCB.  This setup is illustrated in Figure 1. 

http://www.totalphase.com/products/usb-drivers-windows
http://www.totalphase.com/support/articles/200468316-Aardvark-I2C-SPI-Host-Adapter-User-Manual#s3.2
http://www.totalphase.com/products/usb-drivers-linux/
http://www.totalphase.com/support/articles/200468316-Aardvark-I2C-SPI-Host-Adapter-User-Manual#s3.3
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Figure 1 - ECC hardware setup 
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5 Licensing 
EEPROM Command Center uses node-locked, expiring licenses.  The application will not 

function without a license.  When loading the application for the first time or any subsequent 

time without loading a license, you will be presented with the error dialog shown in Figure 4.  

Clicking OK will load the GUI but the main display will be disabled. 

 
Figure 2 - ECC license error dialog 

Licenses can be obtained from Software Forge, Inc. 

 

5.1 License Loading 

In order to load a license: 

1. In the ECC GUI, select Help → Load license. 

2. Perform one of the following in the license load dialog: 

a. Drag your license file from your operating system’s file explorer to the license 

entry area in the ECC window 

b. Open your license file in a text editor, copy all of the text in the file, then paste it 

into the license entry area in the ECC window 

3. Click Apply then OK or just OK to automatically apply 

 
Figure 3 – ECC license load window 

If license loading was successful, the main ECC window will now be enabled and you will have 

full access to the application’s capabilities.  If license loading failed, contact support at Software 

Forge. 
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6 Application Overview 
Figure 4 shows the initial ECC window if license loading was successful. 

 
Figure 4 - ECC initial window 

6.1 Menus 

6.1.1 File Menu 

Menu Item Description 

New Test Creates a new test.  See section Tests. 

Save Snapshot Saves an image snapshot of the main display. 

Save Results Save a summary of results from the cable.  See section Results. 

Save Log Save the log for the current test. 

Save Settings Save settings. See section Settings. 

Save Settings As Save the settings to a new file. 

Open Settings Open a previously saved settings file. 

Exit Closes the application 

 

6.1.2 Tools Menu 

Menu Item Description 

Resume Resumes/starts read execution.  This item will only be visible while 

execution is stopped or paused. 

Pause Pauses read execution.  This item will only be visible while 

execution is running. 

Settings Opens the settings window.  See section Settings. 



  EEPROM Command Center User Manual 

Page 8 of 13 

6.1.3 View Menu 

Menu Item Description 

Open Log Window Opens the log window to display the current log. 

 

6.1.4 Help Menu 

Menu Item Description 

Load License Load a license to enable application functionality.  See section 

License Loading. 

Open User Manual Opens this user manual in the system default PDF viewer. 

About Opens the About window to display application information. 

 

6.2 Button Toolbar 

Image Action Description 

 
New Test Creates a new test.  See section Tests. 

 
Resume 

Resumes/starts read execution.  This button will only be visible 

while execution is stopped or paused. 

 
Pause 

Pauses read execution.  This item will only be visible while 

execution is running. 

 
Settings Opens the settings window.  See section Settings. 

 
Save Settings Save settings. See section Settings. 

 
Save Snapshot Saves an image snapshot of the main display. 

 
Save Results Save a summary of results from the cable.  See section Results. 

 
Save Log Save the log for the current test. 
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6.3 MCB Display 

The MCB display is the bulk of ECC.  It contains a display and controls for each of the MCBs 

controlled by ECC as well as a Load Template dropdown control. 

 

MCB-1 is associated with the transmission (TX) side for ATD testing and so contains indicators 

relevant to transmission of data.  Conversely, MCB-2 is associated with the receiving (RX) side 

for ATD testing and so contains indicators relevant to reception of data. 

 

The top of each MCB display contains a color-coded status for that MCB’s execution.  Each 

MCB starts in the stopped state and each are controlled by the same execution controls.  See 

section Read Execution for more information on execution. 

 

Status indicators are only updated when reading the memory map of the device and so they 

always represent the current state of the memory map.  A field is never updated at any other time 

or for any other reason (including writeable indicators). 

 

6.3.1 Writeable Fields 

The left column of each MCB display contains writable controls which will write the displayed 

value to the associated field of the memory map when clicked.  The current value will be 

displayed as green when read execution is enabled (see section Read Execution).  After writing 

to the memory map, the value of the indicator should change to the written value after the next 

read of the memory map.  If it does not, check the log for errors.  

 

6.3.2 Read-only Fields 

The right column of each MCB contains read-only displays of the memory maps.  These displays 

are here for monitoring purposes only.  The temperature field displays the current temperature of 

the QSFP device as reported in its memory map.  Each status indicator displays the state of the 

associated interrupt flag.  As opposed to the write fields, the numbers in these indicators 

represent different channels and so each indicator represents a different bit in the memory map.  

The status indicators are color coded according to Table 1. 

 

Table 1 - Interrupt flag status indicator colors/status. 

Color Alarm State Description 

Green Cleared 
The interrupt flag is not currently set (i.e. it is cleared to 0) and has not 

been set since the start of read execution. 

Red Set The interrupt flag is currently set. 

Yellow 
Previously 

Set 

The interrupt flag is not currently set, however, it was set at some point 

since the start of read execution.  This state is necessary since the 

behavior for QSFP device is that they will clear an interrupt flag after it 

is read.  Since ECC is constantly reading all of the interrupt flags, the 

flags are constantly being cleared and so it would be easy to miss that a 

flag was set on the display without this state. 
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6.3.3 Additional Controls 

The MCB display also contains the following additional controls: 

 

6.3.3.1 Alarm Reset 

This button resets the interrupt flag alarm state (see section Read-only Fields).  This has the 

effect of forgetting the “Previously Set” state of all interrupt flag status indicators.  After the next 

read of the memory maps, no interrupt flag will be displayed as yellow; all interrupt flags will be 

displayed as either green or red depending on the values read from the memory map.  However, 

it will be possible for the “Previously Set” state to be set again in the future. 

 

6.3.3.2 Aardvark Select 

This dropdown menu will automatically be populated with all Aardvarks connected to the system 

running ECC.  Each Aardvark is identified by its serial number which is usually located under 

the bar code label of on the physical adapter.  Selecting an Aardvark device from the dropdown 

will select which Aardvark is used by that MCB display.  The Aardvarks will be re-discovered 

every time one of the dropdowns is clicked and so changes to which Aardvarks are connected to 

the system will be detected. 

 

6.3.3.3 Templates 

This dropdown menu contains pre-configured templates which represent configurations for the 

memory maps of both QSFP devices.  Selecting one of these templates will write to the memory 

maps of both QSFP devices as follows: 

 

 All Zero: Writes zero to the following fields for both QSFP devices: 

o RX Amplitude Control 

o Clock Recovery 

o TX CTLE 

 Semi-Retimed: Sets the cable to semi-retimed 

o RX Amplitude Control is cleared to zero for both MCBs 

o Clock Recovery is cleared to 0 for MCB-2 and TX CR is set for MCB-1 

o TX CTLE is unchanged 

 Fully-Retimed: Sets the cable to fully-retimed  

o RX Amplitude Control is cleared to zero for both MCBs 

o RX CR is set for MCB-2 and TX CR is set for MCB-1 

o TX CTLE is unchanged 

 

The X button next to the template dropdown is used to clear the template selection.  This merely 

clears the selection and does not write anything to the devices.  This is useful if you select a 

template and then change the configuration with the writeable controls and then would like to 

configure back to the selected template. 
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7 Tests 
Tests in ECC represent a test run with a single DUT.  A single set of results and a log are 

associated with a test.  A new test will automatically be created when first opening the 

application and can be done manually at any time by pressing the New Test menu item or button 

on the toolbar.  Creating a new test will create a new log and will reset all results.  Without 

creating a new test between DUTs, the results and log will contain data for multiple devices and 

so it is important to always create a new test when switching devices or test scenarios. 

 

8 Read Execution 
Read execution is the process of performing consecutive reads of the memory maps of the 

connected devices through the Aardvark adapters.  When ECC is initially started, read execution 

is in the stopped state and no monitoring of the devices will be enabled.  Additionally, write 

controls will not be enabled while read execution is stopped. 

 

In order to start read execution, press the Resume menu item or button on the toolbar.  This will 

not be possible without first selecting an Aardvark device for each MCB in the associated 

Aardvark Select dropdown menu.  Once read execution has started, both MCB status indicators 

should display “Running” and the memory map status indicators should display the current state 

read from the memory map. 

 

By default, reads will be done as fast as possible only limited by the amount of time it takes to 

perform a read through the Aardvark adapters.  A delay can be added between each read by 

setting the read delay in the settings menu (see section Settings). 

  



  EEPROM Command Center User Manual 

Page 12 of 13 

9 Settings 
The settings window can be opened via the Tools → Settings menu item or the Settings button on 

the toolbar.  The settings menu is shown in Figure 5.  The settings shown in Table 2 can be 

configured in this menu. 

 

 
Figure 5 - ECC settings window 

Table 2 - Configurable settings 

Setting Description 

Sample Delay The delay between read execution samples.  The default is 0 which 

is no delay between reads (reads as fast as possible).  The units are 

in milliseconds. 

QSFP Password The password to write to the QSFP memory map password entry 

field.  The Write TX Password button will write this value to the 

QSFP device connected to MCB-1 and the Write RX Password 

button will write the same value to the QSFP device connected to 

MCB-2.  Entering the password should not be necessary for normal 

functionality of the application. 

 

Pressing the OK button in the settings window will apply the settings if any were changed.  The 

cancel button will cancel any changes (any writes to the memory map are still performed but the 

password will not be preserved). 

 

The settings can then be saved to file in order to be loaded on a subsequent application launch 

via the File → Save Settings or File → Save Settings As menu items or the Save Settings button 

on the toolbar.  When ECC is launched, it will automatically load the last saved settings file.  

Additionally, a specific settings file can be loaded via the File → Load Settings menu item. 

  



  EEPROM Command Center User Manual 

Page 13 of 13 

10 Results 
Results from a DUT as well as statistics gathered during a test can be saved to file using the File 

→ Save Results menu item or the Save Results button on the toolbar.  Results can currently be 

saved to HTML or XML file formats.  Results contain the information listed in Table 3. 

 

Table 3 - Result contents 

Field Description 

Vendor Data Data about the vendor of the cable.  This is gathered from the memory map. 

User Data Data about the user of ECC.  This is gathered from the OS. 

Device Data Data about the device.  This includes the serial number and device 

capabilities gathered from the memory map. 

Statistics These are statistics gathered by ECC during the course of a test. 

Map Dumps These are dumps of the complete memory map in both byte format and 

parsed field format.  There are 4 different dumps in this section: 

 TX initial map 

o The map read at the start of the test for the QSFP device 

connected to MCB-1. 

 TX ending map 

o The map read at the end of the test (just before results are 

saved) for the QSFP device connected to MCB-1. 

 RX initial map 

o The map read at the start of the test for the QSFP device 

connected to MCB-2. 

 RX ending map 

o The map read at the end of the test (just before results are 

saved) for the QSFP device connected to MCB-2. 

 

Results are cleared whenever a new test is created.  See section Tests for more details. 

 

11 Known Issues 
The following are known issues of ECC: 

 If the Aardvark Select dropdown shows Aardvark serial numbers that do not match the 

connected Aardvarks, disconnect and reconnect the Aardvark USB cables. This appears 

to be a rare issue with the Aardvark API/Driver. 


