[openib-general] cma header - change some things according to the list feedback

Guy German guyg at voltaire.com
Thu Aug 25 11:29:48 PDT 2005


Hi James,

Sorry for breaking the thread
(Replying from home - outlook web interface)

> typedef void (*ib_cma_rarp_handler)(struct sockaddr *src_ip, void *context);
>>How about ib_cma_addr_handler? By using the string rarp, you imply 
>>that RARP is being used.

OK.

> typedef void (*ib_cma_ac_handler)(enum ib_cma_event event, void *context);
> typedef void (*ib_cma_event_handler)(enum ib_cma_event event, void *context,
> 				     void *private_data);
>>Would ib_cma_conn_handler be more appropriate?

Maybe, but it is actually the active side event cb (also for discon etc.)
I don't mind changing it, though...

> int ib_cma_connect(struct ib_cma_conn *cma_conn,
> 		   union ib_cma_id *cma_id);
> 
>> Should there be a way to cancel an ib_cma_connect() call? 

It is possible to add it. Not sure how much it will be used by 
consumers, though.

> int ib_cma_sid_listen(struct ib_device *device, struct sockaddr *address,
> 		      __be64 service_id, void *context,
> 		      ib_cma_listen_handler cm_listen_handler,
> 		      union ib_cma_id *cma_id);
>>Given the new sockaddr parameter, I think you should rename this 
>>function ib_cma_listen().

True ;)

> int ib_cma_sid_destroy(union ib_cma_id *cma_id);
>>I'd also change this to ib_cma_destroy().

Right.

Thanks,
Guy.



More information about the general mailing list