[openib-general] [PATCH 1/7] AMSO1100 Kconfig and Makefiles

Roland Dreier rdreier at cisco.com
Wed Mar 8 10:44:43 PST 2006


 > --- hw/amso1100/Makefile	(revision 0)
 > +++ hw/amso1100/Makefile	(revision 0)
 > @@ -0,0 +1,22 @@
 > +EXTRA_CFLAGS += -Idrivers/infiniband/include
 > +
 > +ifdef CONFIG_INFINIBAND_AMSO1100_DEBUG
 > +EXTRA_CFLAGS += -DC2_DEBUG
 > +endif
 > +
 > +obj-$(CONFIG_INFINIBAND_AMSO1100) += iw_c2.o
 > +
 > +iw_c2-y := \
 > +	c2.o \
 > +	c2_provider.o \
 > +	c2_rnic.o \
 > +	c2_alloc.o \
 > +	c2_mq.o \
 > +	c2_ae.o \
 > +	c2_vq.o \
 > +	c2_intr.o \
 > +	c2_cq.o \
 > +	c2_qp.o \
 > +	c2_cm.o \
 > +	c2_mm.o \
 > +	c2_pd.o

Two minor picky things here:
 - It would be good to name this file "Kbuild" instead.  "Makefile" is
   somewhat deprecated as a name for kernel build files, and we might
   as well use the new preferred name for new files
 - move the files in the iw_c2-y := line to be on one or two lines
   instead of spread out as they are.  It doesn't really matter here
   but for bigger files it makes it a lot easier to read, and we should
   follow the general kernel idiom.



More information about the general mailing list