[openib-general] [PATCH] IB/sa: fix ib_sa_selector names

Michael S. Tsirkin mst at mellanox.co.il
Mon Sep 18 12:17:08 PDT 2006


IB/sa: Fix ib_sa_selector names

Relevant SA queries are actually "greater than"
not "greater than or equal" as the name implies.
See IB spec 1.2 Vol 1, 15.2.5.16 PATHRECORD/Table 205 PathRecord.

Signed-off-by: Michael S. Tsirkin <mst at mellanox.co.il>

Index: linux-2.6.18-rc2-devel/include/rdma/ib_sa.h
===================================================================
--- linux-2.6.18-rc2-devel.orig/include/rdma/ib_sa.h	2006-09-17 11:54:38.000000000 +0300
+++ linux-2.6.18-rc2-devel/include/rdma/ib_sa.h	2006-09-17 11:54:51.000000000 +0300
@@ -79,8 +79,8 @@ enum {
 };
 
 enum ib_sa_selector {
-	IB_SA_GTE  = 0,
-	IB_SA_LTE  = 1,
+	IB_SA_GT   = 0,
+	IB_SA_LT   = 1,
 	IB_SA_EQ   = 2,
 	/*
 	 * The meaning of "best" depends on the attribute: for

-- 
MST




More information about the general mailing list