[ofa-general] [PATCHv2] IB/mad: Change SMI to use enums rather than magic return codes

Roland Dreier rdreier at cisco.com
Thu Apr 12 10:36:48 PDT 2007


Definitely a big improvement to readability.  However, I don't like
the "smi_type" name, since the enum is not really a type but rather an
action:

 > +enum smi_type {
 > +	IB_SMI_DISCARD,
 > +	IB_SMI_HANDLE
 > +};
 > +
 > +enum smi_forward_type {
 > +	IB_SMI_LOCAL,	/* SMP should be completed up the stack */
 > +	IB_SMI_SEND,	/* received DR SMP should be forwarded to the send queue */
 > +};

Is it OK if I do s/smi_type/smi_action/ and s/smi_forward_type/smi_forward_action/
before applying this?

 - R.



More information about the general mailing list