[ewg] [PATCH 1/2 v2]libibvers: add create_qp_expanded

Ron Livne ronli.voltaire at gmail.com
Tue Aug 19 04:44:26 PDT 2008


OK, but doesn't it contradict the approach you agreed on?

 > What do you think of the following approach?
 > Instead of adding creation flags to the qp_init_attr, I can add a new verb:
 > ibv_qp *create_qp_extended(struct ibv_pd *pd, struct ibv_qp_init_attr,
 > *init_attr, enum ibv_qp_create_flags create_flags)
 >
 > I'm aware that adding a new verb isn't optimal, but at least we can
 > avoid incrementing the libibverbs version.

I think this new verb seems like a better approach right now.



On Tue, Aug 12, 2008 at 10:37 PM, Roland Dreier <rdreier at cisco.com> wrote:
> Sorry for jumping in so late in the process, but a few big concerns:
>
>  >         struct ibv_qp *ibv_create_qp_expanded(struct ibv_pd *pd,
>  >                                struct ibv_qp_init_attr *qp_init_attr,
>  >                                uint32_t create_flags);
>
> I don't like the name "_expanded" when all we are doing is adding a
> flags parameter.  The next time we need to tweak this API, then we end
> up with _extra_super_expanded or something like that.
>
> I see two better options: keep the same prototype but call it something
> like ibv_create_qp_with_flags (or maybe ibv_create_qp_flags), or keep
> the name ibv_create_qp_expanded but instead of create_flags, have the
> new parameter be ext_mask, have one bit in ext_mask indicate create
> flags, and add create_flags to struct ibv_qp_init_attr -- then we can
> add more extra stuff by using more bits in ext_mask.
>
> Also, I wonder if it's worth a new verb in the kernel ABI for this.
> Maybe we should add a new command in the ABI where libibverbs can pass
> in a bitmask of supported extensions, and the kernel can respond with
> which extensions it supports.  And then we can just continue to use the
> reserved field in the existing create_qp command if both kernel and
> userspace agree that they support create flags there.
>
>  - R.
> _______________________________________________
> ewg mailing list
> ewg at lists.openfabrics.org
> http://lists.openfabrics.org/cgi-bin/mailman/listinfo/ewg
>



More information about the ewg mailing list