[ofiwg] noob questions

Don Fry DFry at lightfleet.com
Wed Nov 13 10:54:04 PST 2019

I have written a libfabric provider for our hardware and it passes all the fabtests I expect it to (dgram and msg).  I am trying to run some MPI tests using libfabrics under openmpi (4.0.2).  When I run a simple ping-pong test using mpirun it sends and receives the messages using the tcp/ip protocol.  It does call my fi_getinfo routine, but doesn't use my provider send/receive routines.  I have rebuilt the libfabric library disabling sockets, then again --disable-tcp, then --disable-udp, and fi_info reports fewer and fewer providers until it only lists my provider, but each time I run the mpi test, it still uses the ip protocol to exchange messages.

When I configured openmpi I specified --with-libfabric=/usr/local/ and the libfabric library is being loaded and executed.

I am probably doing something obviously wrong, but I don't know enough about MPI or maybe libfabric, so need some help. If this is the wrong list, redirect me.


Any suggestions?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openfabrics.org/pipermail/ofiwg/attachments/20191113/44935cc7/attachment.html>

More information about the ofiwg mailing list