[ofw] [PATCH] typeof() not supported in Windows WDK compiler
Smith, Stan
stan.smith at intel.com
Thu Oct 1 16:14:12 PDT 2009
Hefty, Sean wrote:
>> diff --git a/opensm/opensm/osm_drop_mgr.c
>> b/opensm/opensm/osm_drop_mgr.c index 4f98cc9..8fe5129 100644 ---
>> a/opensm/opensm/osm_drop_mgr.c +++ b/opensm/opensm/osm_drop_mgr.c
>> @@ -209,8 +209,13 @@ static void drop_mgr_remove_port(osm_sm_t * sm,
>> IN osm_port_t * p_port) drop_mgr_clean_physp(sm, p_port->p_physp);
>>
>> while (!cl_is_qlist_empty(&p_port->mcm_list)) {
>> +#ifndef __WIN__
>> mcm_port = cl_item_obj(cl_qlist_head(&p_port->mcm_list),
>> mcm_port, list_item);
>> +#else
>> + mcm_port = cl_item_obj(cl_qlist_head(&p_port->mcm_list),
>> + mcm_port, list_item, (osm_mcm_port_t*) );
>> +#endif
>
> I'd find this more readable if it were #ifdef rather than #ifndef.
So would I, although the convention is to only define something extra for Windows.
Perhaps a gcc/cpp defined item could be recommended and agreed upon?
>
> That said, I've got to believe that there's a better way to handle
> these changes. I just don't know what it is.
Agreed, I'm listening.
More information about the ofw
mailing list