[ofw] [IPOIB_NDIS6_CM] IPOIB_INLINE_RECV readability patch

Hefty, Sean sean.hefty at intel.com
Mon Aug 9 12:04:06 PDT 2010


> >rq_depth * p_params->recv_pool_ratio,
> +                                                          0,
> +                                                          0,
> +
> sizeof(ipoib_recv_desc_t),
> +                                                          __recv_ctor,
>  #if IPOIB_INLINE_RECV
> -               0, 0, sizeof(ipoib_recv_desc_t), __recv_ctor, NULL, p_port
> );
> -#else  /* IPOIB_INLINE_RECV */
> -               0, 0, sizeof(ipoib_recv_desc_t), __recv_ctor, __recv_dtor,
> p_port );
> -#endif /* IPOIB_INLINE_RECV */
> +                                                          NULL,
> +#else
> +                                                          __recv_dtor,
> +#endif
> +                                                          p_port );
> +

Ugh - how about we place the #if around each function call, rather than trying to separate out the parameters?

exactly the way this was:

>  #if IPOIB_INLINE_RECV
> -                       __endpt_mgr_get_by_gid( p_port, &p_desc-
> >buf.ib.grh.src_gid );
> -#else  /* IPOIB_INLINE_RECV */
> -                       __endpt_mgr_get_by_gid( p_port, &p_desc->p_buf-
> >ib.grh.src_gid );
> -#endif /* IPOIB_INLINE_RECV */
> +                                                                 &p_desc-
> >buf.ib.grh.src_gid
> +#else
> +                                                                 &p_desc-
> >p_buf->ib.grh.src_gid
> +#endif

This is much easier to read IMO.




More information about the ofw mailing list