[libfabric-users] IB: Resource temporarily unavailable

Ilango, Arun arun.ilango at intel.com
Wed Mar 9 13:56:01 PST 2016

Verbs RDM support is still experimental. rdm pinpong test returns -FI_ENODATA because verbs-RDM doesn't support FI_MSG capability. Also, other RDM tests are not guaranteed to run on verbs for now. Complete support for RDM in verbs is a work in progress.

-----Original Message-----
From: François Tessier [mailto:ftessier at anl.gov] 
Sent: Wednesday, March 09, 2016 11:53 AM
To: Ilango, Arun <arun.ilango at intel.com>; Jose, Jithin <jithin.jose at intel.com>; Hefty, Sean <sean.hefty at intel.com>; libfabric-users at lists.openfabrics.org
Subject: Re: [libfabric-users] IB: Resource temporarily unavailable

Hi Arun,

Thank you. I confirm that it works now!

Another issue however appears while using the RDM ping pong with IB.
Even though it works with sockets, I get a -FI_ENODATA when I try to run it with verbs. An idea why?



On 03/08/2016 12:02 PM, Ilango, Arun wrote:
> Hi François,
> Just an update: The issue is fixed in the verbs provider and the msg_pingpong test should run fine on latest libfabric. Please give it a try.
> Thanks,
> Arun.
> -----Original Message-----
> From: libfabric-users-bounces at lists.openfabrics.org 
> [mailto:libfabric-users-bounces at lists.openfabrics.org] On Behalf Of 
> Jose, Jithin
> Sent: Tuesday, February 16, 2016 11:46 AM
> To: Hefty, Sean <sean.hefty at intel.com>; François Tessier 
> <ftessier at anl.gov>; libfabric-users at lists.openfabrics.org
> Subject: Re: [libfabric-users] IB: Resource temporarily unavailable
> It looks like the fabtests does not handle the -FI_EAGAIN error. Currently it just reports error and exits.
> - Jithin
> -----Original Message-----
> From: "Hefty, Sean" <sean.hefty at intel.com>
> Date: Tuesday, February 16, 2016 at 11:42 AM
> To: François Tessier <ftessier at anl.gov>, Jithin Jose 
> <jithin.jose at intel.com>, "libfabric-users at lists.openfabrics.org" 
> <libfabric-users at lists.openfabrics.org>
> Subject: RE: [libfabric-users] IB: Resource temporarily unavailable
>> Thanks - since Arun mentioned that he can reproduce this, we can probably debug it from there.  The ucmatose errors that you hit are just a mismatch in the data transfer parameters.  Otherwise, I think the lower layer is working okay.
>> - Sean
>>> Here are some outputs :
>>> - ibv_devinfo :
>>> http://pastebin.aquilenet.fr/?336dc870bee715b1#LV8ZCP9Pw2YaaCDK1KuiQ
>>> wYweSd
>>> Od2+dNZnHSnQjOOU=
>>> - ibv_rc_pingpong :
>>> http://pastebin.aquilenet.fr/?d04a2e1f67aac37d#46UqQuDBY+/iz8TxZmEfh
>>> k3rPKN
>>> uXCSljlnHl8VDCiI=
>>> - ucmatose :
>>> http://pastebin.aquilenet.fr/?0ce1dc156dd92bd7#eOMTUz3ueKUhSe0/5rPz/
>>> yrTdFm
>>> BiafBwvWVA16fWXg=
>>> Not sure if I ran these applications well...
>>> Regards,
>>> François
>>> On 16/02/2016 12:24, Hefty, Sean wrote:
>>>> If you can, please test the verbs installation by running 
>>>> ibv_devinfo,
>>> ibv_rc_pingpong, and ucmatose.
> _______________________________________________
> Libfabric-users mailing list
> Libfabric-users at lists.openfabrics.org
> http://lists.openfabrics.org/mailman/listinfo/libfabric-users

More information about the Libfabric-users mailing list