[libfabric-users] RDM send fails

Jörn Schumacher jorn.schumacher at cern.ch
Tue Nov 27 03:09:40 PST 2018


Since a couple of days I am trying to use libfabric RDM endpoints (so 
far I only worked with connected endpoints) to send a single message 
between two applications. I am using libfabric 1.6.1 with the verbs/RxM 

My attempt is based on the example from the tutorial here: 

A stripped-down version of my code is here:

Q1: I run into the issue that fi_send returns FI_EAGAIN, indicating that 
some resource is not available. What could be the issue? I have QP, AV 
and a registered buffer, to my understanding nothing else is needed for RDM.

Q2: It is not clear to me what arguments I have to supply for 
node/service for the fi_getinfo call on the sender side. In the tutorial 
the destination address is used, but that does not make sense if I have 
multiple destinations. I cannot put NULL for both as that yields -61(No 
data available).

Thanks in advance.


More information about the Libfabric-users mailing list