[ofiwg] exposing hardware limits via libfabric

Hefty, Sean sean.hefty at intel.com
Fri Sep 21 12:02:12 PDT 2018


> - I assume "cnt" is "count".  Are we allergic to vowels?  :-)

Why yes I am.  Thank you for your concern.

I was matching the existing naming convention, which uses 'cnt'.  Other names similarly reference some existing fields.  But we can work on the names.

> - Is "cn_cnt" a typo for "cq_count" :-) ?

Yes

> - Is "size" the maximum size of something?

Yes

> - Is "count" the number of items currently used?

No - maximum number of items available (likely statically defined).

These would all be part of a struct fi_device_limits, which I'm hoping is clear enough that these are maximum hardware limits.  There would be a correlation with existing fields where possible.  E.g. (based on my sample names)

These are optimal values   -> This are maximum limitations
------------------------      ----------------------------
fi_tx_attr::size           -> fi_device_limits::tx_size
fi_rx_attr::size           -> fi_device_limits::rx_size
fi_cq_attr::size           -> fi_device_limits::cq_size
fi_av_attr::count          -> fi_device_limits::av_size (messed this one up)
fi_domain_attr::cq_cnt     -> fi_device_limits::cq_cnt
fi_domain_attr::tx_ctx_cnt -> fi_device_limits::tx_cnt (change to tx_ctx_cnt)
fi_domain_attr::rx_ctx_cnt -> fi_device_limits::rx_cnt (change to rx_ctx_cnt)
fi_domain_attr::ep_cnt     -> fi_device_limits::ep_cnt
new                        -> fi_device_limits::stx_cnt (change to stx_ctx_cnt)
new                        -> fi_device_limits::srx_cnt (change to srx_ctx_cnt)
new                        -> fi_device_limits::av_cnt


- Sean



More information about the ofiwg mailing list