[libfabric-users] fi_getname "Operation not permitted in current state"

Biddiscombe, John A. biddisco at cscs.ch
Fri Jun 15 00:01:40 PDT 2018


Thanks for the feedback. I had discovered that by adding an fi_enable beforehand, it works, but I am puzzled as to why it worked fine on gni, but not sockets. I need to debug it more and see if the two are taking different paths through other bits of code that I didn't realize.

With gni, we are using pmi for our boot sequence, and probably, something is different in our startup code.


From: Hefty, Sean [sean.hefty at intel.com]
Sent: 14 June 2018 18:13
To: Biddiscombe, John A.; libfabric-users at lists.openfabrics.org
Subject: RE: [libfabric-users] fi_getname "Operation not permitted in current   state"

> I tried using the sockets provider on some code that worked fine on
> the gni provider.
> I didn't spend a lot of time on this yet (mostly because I've
> forgotten what the code does as it's been a year since I looked at it)
> Is there a common problem that results in this error?

It's really hard to say without more detail.  :)  As a total guess, is the endpoint in an enabled state?  I don't know when sockets assigns an address to an endpoint.

- Sean

More information about the Libfabric-users mailing list